Elevated Network Errors
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 15, 2017 - 09:16 EDT
Investigating
We're experiencing an elevated level of network errors and are currently looking into the issue.
Posted almost 2 years ago. Sep 15, 2017 - 08:38 EDT