Performance degradation
Incident Report for Sync.com
Resolved
This has been resolved. Contact help@sync.com if you are still experiencing issues.
Posted about 2 years ago. May 25, 2017 - 14:58 EDT
Update
Our network engineers continue to investigate delayed uploads and downloads from the desktop apps
Posted about 2 years ago. May 25, 2017 - 14:39 EDT
Investigating
Our network engineers are investigating intermittent desktop app uploads
Posted about 2 years ago. May 25, 2017 - 13:20 EDT