Elevated Errors
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 02, 2019 - 13:52 EDT
Investigating
We're experiencing an elevated level of sign in errors and are currently looking into the issue.
Posted 6 months ago. Apr 02, 2019 - 13:18 EDT
This incident affected: Web Panel and Desktop.