Elevated Errors
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 05, 2018 - 10:28 EDT
Investigating
We're experiencing an elevated level of errors and are currently looking into the issue.
Posted over 1 year ago. Apr 05, 2018 - 09:36 EDT