Elevated network errors
Incident Report for Sync.com
Resolved
We continue to monitor, but it looks like this issue is resolved.
Posted almost 2 years ago. Nov 07, 2017 - 14:20 EST
Investigating
We're experiencing an elevated level of network errors and are currently looking into the issue.
Posted almost 2 years ago. Nov 07, 2017 - 13:08 EST