Elevated network errors
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 07, 2017 - 05:19 EST
Investigating
We're experiencing an elevated level of network errors and are currently looking into the issue.
Posted almost 2 years ago. Nov 06, 2017 - 18:39 EST