Elevated Errors
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 26, 2018 - 15:46 EST
Update
We are continuing to investigate this issue.
Posted 8 months ago. Nov 26, 2018 - 15:01 EST
Investigating
We're experiencing an elevated level of errors and are currently looking into the issue.
Posted 8 months ago. Nov 26, 2018 - 15:00 EST
This incident affected: Web Panel, Desktop, and Mobile.