Ongoing maintenance
Incident Report for Sync.com
Resolved
Maintenance has been concluded.
Posted over 1 year ago. Mar 02, 2018 - 20:04 EST
Monitoring
We are currently preforming maintenance on our platform.
Posted over 1 year ago. Mar 02, 2018 - 19:35 EST