Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2024 - 23:55 EST
Scheduled
We will be undergoing scheduled maintenance during this time. A subset of users will experience issues or see an error message while uploading or downloading files.
Posted Dec 03, 2024 - 11:24 EST
This scheduled maintenance affected: Sync Software Clients (Windows Desktop, Android Mobile Client, Mac Desktop, iOS Mobile Client), Platform Services (Links, Admin tools (Pro Teams), Events, Shared Folders), and Control Panel.