Some users may experience degraded performance when accessing Sync
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 22:25 EDT
Investigating
We are currently investigating the error messages users are reporting while accessing Sync.
Posted Jul 19, 2023 - 14:39 EDT
This incident affected: Website, Web Panel, Links, Shared Folders, and Events.