Performance degradation
Incident Report for Sync.com
Resolved
This has been resolved. Contact help@sync.com if you are still experiencing issues.
Posted over 2 years ago. May 31, 2017 - 14:26 EDT
Investigating
Our network engineers are investigating delayed desktop app downloads
Posted over 2 years ago. May 31, 2017 - 13:13 EDT