Download Issues with Links
Incident Report for Sync.com
Resolved
This issue has been resolved.
Posted 10 months ago. Dec 06, 2018 - 13:01 EST
Identified
We're experiencing an elevated level of download errors via links and are currently looking into the issue.
Posted 10 months ago. Dec 06, 2018 - 08:16 EST
This incident affected: Links.