Some users may experience issues with submitting orders for purchasing Sync accounts
Incident Report for Sync.com
Resolved
This incident has been resolved.
Posted Oct 23, 2023 - 10:40 EDT
Monitoring
A fix has been implemented by our vendor and we will continue to monitor. Users should be able to submit orders for new, renewals and upgrades to their accounts as well as being able to update billing information and view previous invoices
Posted Oct 23, 2023 - 10:28 EDT
Identified
Sync's payment processing vendor is experiencing an issue. Our Engineer team is investigating alongside our vendor to restore services.
During this time New Sync customers may not be able to submit an order to purchase a new Sync plan. Existing users may have trouble accessing and updating their billing information, accessing invoices, submitting a renewal and/or upgrading their current plan.
Posted Oct 23, 2023 - 09:49 EDT